jmfs.net
当前位置:首页>>关于Ubuntu16.04 安装opencv2.4时,在make时出现了错误...的资料>>

Ubuntu16.04 安装opencv2.4时,在make时出现了错误...

/usr/local/lib/libjpeg.so动态链接库文件有问题,检查一下

找不到头文件的原因 .要么当前指定的头文件各个目录不包含这个头文件所在的目录;要么这个头文件根本不存在.解决方法:在工程属性中“C++目录”里,把<opencv_path>\build\include或类似的include目录添加到头文件目录

可能是g++的版本老,不支持-fvisibility-inlines-hidden开关,这个是私有化内联函数的.

opencv 2.2以后版本需要使用cmake生成makefile文件,因此需要先安装cmake.ubuntu下安装cmake比较简单,apt-get install cmakeapt-get install libgtk2.0-dev(下面两步安装编译必须的库)apt-get install pkg-config然后你们下载openc-2.4.3

很明显是./configure 忘记加上参数,为/xxx/glibc-2.14/glibc-build/versions.all指定编译规则.

用下面的这个命令是可以编译通过的,但有俩个警告 arm-linux-g++ -o opencv_test.o test.c -I /usr/local/include/opencv -L /usr/local/lib -lopencv_core -lopencv_highgui -lpthread -lrt 运行上面的命令之前,要将 opencv2 这个目录复制到 opencv下,这

都是warning,没有错误,连接也成功,执行码也生成了,运行试试

mips工具链有问题,file mipsel-linux-uclibc-gcc ,看看它是在多少位的系统上用的?

试试这个教程:www.yyearth.com/article/13-12/opencv.html

ubuntu虚拟机?你是要ubuntu还是虚拟机?

相关文档
zxqk.net | rpct.net | realmemall.net | gtbt.net | zmqs.net | 网站首页 | 网站地图
All rights reserved Powered by www.jmfs.net
copyright ©right 2010-2021。
内容来自网络,如有侵犯请联系客服。zhit325@qq.com